Virtual LAN

Tujuan
* Agar dapat memahami apa yang dimaksud dengan VLAN dan bagaimana cara kerja VLAN
* Agar dapat mengkonfigurasikan VLAN dengan menggunakan Cisco Packet Tracer

Landasan teori
Definisi
Virtual Local Area Network (VLAN) adalah metode untuk menciptakan jaringan-jaringan yang secara logika tersusun sendiri-sendiri. VLAN sendiri berada dalam jaringan Local Area Network (LAN), sehingga dalam jaringan (LAN) bisa terdapat satu atau lebih VLAN. Dengan demikian kita dapat mengambil kesimpulan bahwa dalam dalam suatu jaringan, kita dapat membuat lagi satu atau lebih jaringan (jaringan di dalam jaringan).

VLAN juga merupakan model jaringan yang tidak terbatas pada lokasi fisik seperti LAN, hal ini mengakibatkan suatu jaringan dapat dikonfigurasi secara
virtual tanpa harus menuruti lokasi fisik peralatan. Penggunaan VLAN akan membuat pengaturan jaringan menjadi sangat fleksibel dimana dapat dibuat segmen yang bergantung pada organisasi atau departemen, tanpa bergantung pada lokasi workstation.

Virtual LAN (VLAN) memberikan suatu metoda yang sangat fleksibel untuk mengatur segmen-segmen jaringan menggunakan Switch LAN. Jika menggunakan VLAN dalam jaringan-jaringan yang mempunyai Switches yang saling terhubung, VLAN trunking antar switches diperlukan.

VLAN memberikan suatu fleksibilitas managemen dalam membuat Virtual LAN terpisah menjadi segment-segment atau subnet-subnet yang bisa digunakan untuk mendefinisikan lokasi terpisah atau jaringan-jaringan departemental. Penggunaan Virtual LAN dalam suatu jaringan LAN bersifat opsional dan biasanya dipengaruhi oleh kebutuhan-kebutuhan tertentu yang khusus seperti misalnya alasan keamanan dan pemisahan departemen.

Konsep
Sebelum memahami Virtual LAN, suatu pengertian khusus mengenai definisi suatu LAN diperlukan. Sebuah LAN meliputi semua piranti jaringan yang berada pada satu broadcast domain. Suatu broadcast domain meliputi sekelompok piranti jaringan yang terhubung dalam suatu jaringan LAN yang bisa mengirim frame broadcast, dan semua piranti lainnya dalam satu segmen LAN yang sama akan menerima salinan frame broadcast tersebut. jadi bisa dikatakan bahwa suatu jaringan LAN dan suatu broadcast domain pada prinsipnya adalah hal yang sama.

Tanpa VLAN, sebuah Switch akan memperlakukan semua antarmuka pada Switch tersebut berada pada broadcast domain yang sama – dengan kata lain, semua piranti yang terhubung ke Switch berada dalam satu jaringan LAN. Dengan adanya VLAN, sebuah switch bisa mengelompokkan satu atau beberapa antarmuka (baca: port) berada pada suatu VLAN sementara antarmuka lainnya berada pada VLAN lainnya. Jadi pada dasarnya, Switch membentuk beberapa broadcast domain. Masing-masing broadcast domain yang dibuat oleh Switch ini disebut virtual LAN.

Keuntungan
Keuntungan VLAN adalah mengizinkan admin jaringan untuk mengorganisasi LAN secara logika dan bukannya secara fisik. Ini berarti bahwa admin dapat melakukan semuanya, termasuk:
- Memindahkan workstation pada LAN
- Menambah workstation pada LAN
- Mengubah konfigurasi LAN
- Memantau lalulintas jaringan
- Meningkatkan keamanan

Jenis
Berdasarkan perbedaan pemberian membership, maka VLAN bisa dibagi menjadi empat, yakni:
a. Port based
Dengan melakukan konfigurasi pada port dan memasukkannya pada kelompok VLAN sendiri. Apabila port tersebut akan dihubungkan dengan beberapa VLAN maka port tersebut harus berubah fungsi menjadi port trunk (VTP)

b. MAC based
Membership atau pengelompokan pada jenis ini didasarkan pada MAC Address. Tiap switch memiliki tabel MAC Address tiap komputer beserta kelompok VLAN tempat komputer itu berada

c. Protocol based
Karena VLAN bekerja pada layer 2 (OSI) maka penggunaan protokol (IP dan IP Extended) sebagai dasar VLAN dapat dilakukan

d. IP Subnet Address based
Selain bekerja pada layer 2, VLAN dapat bekerja pada layer 3, sehingga alamat subnet dapat digunakan sebagai dasar VLAN

e. Authentication based
Device atau komputer bisa diletakkan secara otomatis di dalam jaringan VLAN yang didasarkan pada autentifikasi user atau komputer menggunakan protokol 802.1x

Sedangkan dari tipe koneksi dari VLAN dapat di bagi atas 3, yaitu:
1. Trunk Link
2. Access Link
3. Hibrid Link (Gabungan Trunk dengan Access)

Prinsip kerja
# Filtering Database
Berisi informasi tentang pengelompokan VLAN. Terdiri dari:
1. Static Entries
a. Static Filtering Entries:
Menspesifikasikan apakah suatu data itu akan dikirim atau dibuang atau juga dimasukkan ke dalam dinamic entries.
b. Static Registration Entries
Menspesifisifikasikan apakah suatu data itu akan dikirim ke suatu jaringan VLAN dan port yang bertanggung jawab untuk jaringan VLAN tersebut.
2. Dynamic Entries
a. Dynamic Filtering Entries
Menspesifikasikan apakah suatu data itu akan dikirim atau dibuang.
b. Group Registration Entries
Mespesifikasikan apakah suatu data yang dikirim ke suatu group atau VLAN tertentu akan dikirim/diteruskan atau tidak.
c. Dynamic Registration Entries
Menspesifikasikan port yang bertanggung jawab untuk suatu jaringan VLAN.

# Tagging
Saat sebuah data dikirimkan maka harus ada yang menyatakan Tujuan data tersebut (VLAN tujuan). Informasi ini diberikan dalam bentuk tag header, sehingga informasi dapat dikirimkan ke user tertentu saja (user tujuan) dan didalamnya berisi format MAC Address.

Langkah percobaan
Pertama kita buka aplikasinya dengan cara >> Programs >> Packet Tracer, atau klik saja icon-nya langsung dari dekstop dan akan tampil worksheetnya.


Ambil 6 buah PC dari select device box pada bagian end devices dengan cara di drop (ditarik) lalu tempatkan ke logical workspace seperti terlihat pada gambar dibawah ini.


Lalu ganti nama masing-masing PC menjadi : PC1, PC2, PC3, PC4, PC5, PC6. Caranya klik PC, lalu Klik Config, lalu isi nama di Display Name.


Ambil 6 buah Switch dari select device box pada bagian end devices dengan cara di drop (ditarik) lalu tempatkan ke logical workspace seperti terlihat pada gambar dibawah ini.

Hubungkan 6 PC tadi dengan kabel yang sesuai (kabel Straight) ke masing-masing Switch dengan ketentuan sebagai berikut:
PC1 FastEthernet -> Switch2 FastEthernet0/11
PC2 FastEthernet -> Switch2 FastEthernet0/18
PC3 FastEthernet -> Switch2 FastEthernet0/6
PC4 FastEthernet -> Switch3 FastEthernet0/11
PC5 FastEthernet -> Switch3 FastEthernet0/18
PC6 FastEthernet -> Switch3 FastEthernet0/6

Hubungkan masing-masing Switch dengan kabel yang sesuai (kabel Cross) dengan ketentuan sebagai berikut:
Switch2 FastEthernet0/1 -> Switch1 FastEthernet0/1
Switch3 FastEthernet0/3 -> Switch1 FastEthernet0/3

Klik PC yang ada di logical workspace, lalu set alamat IP tiap-tiap PC dengan ketentuan sebagai berikut:
PC1 : 172.17.10.21 Subnet mask : 255.255.255.0
PC2 : 172.17.20.22 Subnet mask : 255.255.255.0
PC3 : 172.17.30.23 Subnet mask : 255.255.255.0
PC4 : 172.17.10.24 Subnet mask : 255.255.255.0
PC5 : 172.17.20.25 Subnet mask : 255.255.255.0
PC6 : 172.17.30.26 Subnet mask : 255.255.255.0

Konfigurasi VLAN pada masing-masing Switch1, Switch2 dan Switch3. Klik Switch – Config – VLAN Database – isi VLAN Number dan VLAN Name sesuai dengan ketentuan berikut:
VLAN Number                                    VLAN Name
10                                                         Faculty
20                                                         Students
30                                                         Guest
99                                                         Management&Native

- Klik 2x pada switch 1 - pilih CLI, masukan script berikut:
Switch>enable
Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#name Faculty/Staff
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name Students
Switch(config-vlan)#vlan 30
Switch(config-vlan)#name Guest(Default)
Switch(config-vlan)#vlan 99
Switch(config-vlan)#name Management&Native
Switch(config-vlan)#end

- Pada Switch 2 dan switch 3, gunakan perintah yang sama yang digunakan pada switch 1 untuk membuat dan nama VLAN.
- Setelah membuat VLAN, kita akan melihat hasilnya, masukkan perintah berikut:
Switch#show vlan brief
- Modus perintah switchport akses mengkonfigurasi antarmuka sebagai port akses. Pada switchport vlan mengakses vlan-id perintah memberikan VLAN ke pelabuhan. Sebuah port akses hanya dapat diberikan kepada satu akses VLAN. Masukkan perintah pada switch 2 dengan cara klik 2x pada switch 2 - pilih CLI dan masukan perintah berikut:
Switch>enable
Switch#configure terminal
Switch(config)#interface fastEthernet 0/6
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#interface fastEthernet 0/11
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#interface fastEthernet 0/18
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#end

- Menetapkan VLAN ke port aktif di switch 3. Switch 3 menggunakan perintah yang sama seperti pada switch 2
- Setelah itu mengkonfigurasi Trunking
- Konfigurasi switch 1 pada FastEthernet0 / 1 dan FastEthernet0 / 3 untuk trunking dan menggunakan VLAN 99 sebagai VLAN asli. Cara nya Klik 2x pada switch 1 - pilih CLI dan masukan perintah seperti berikut:
Switch>enable
Switch#configure terminal
Switch(config)#interface FastEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 99
Switch(config-if)#interface FastEthernet 0/3
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 99


Selain cara di atas, juga bisa menggunakan cara seperti di bawah:

Pengaturan VLAN pada Switch2 dan Switch3

Klik Switch – Config – FastEthernet0/6 – VLAN 30


Klik Switch – Config – FastEthernet0/11 – VLAN 10


Klik Switch – Config – FastEthernet0/18 – VLAN 20


Pengaturan Trunk pada Switch

Klik Switch2 – Config – FastEthernet0/1 – Trunk

Klik Switch3 >> Config >> FastEthernet0/3 >> Trunk

Klik Switch1 >> Config >> FastEthernet0/1 >> Trunk

Klik Switch1 >> Config >> FastEthernet0/3 >> Trunk

Hasil
Untuk mengecek apakah Simulasi Jaringan VLAN yang tadi sudah kita buat berjalan dengan baik atau tidak dapat dilakukang dengan cara mengirimkan paket ICMP. Ikuti langkah-langkah berikut :

Klik Gambar Pesan yang berada disisi kanan aplikasi Packet Tracer, lalu klik PC yang ingin mengirim pesan tersebut. Setelah itu klik PC tujuan dikirimkannya pesan tersebut. Setelah itu klik Simulation dibelakang Realtime.

Lalu klik Edit Filters, hapus tanda centang pada Show All/None, lalu centang ICMP. Setelah itu Klik Auto Capture / Play.

Lalu lihat disisi kanan bawah aplikai Packet Tracer. Apabila di kotak tersebut tertera status Successful, berarti Simulasi Jaringan VLAN yang tadi dibuat berjalan dengan baik.

Disusun oleh:
Arief Rahman
II A
11615022

Komentar

Posting Komentar

Postingan populer dari blog ini

Tutorial Menghilangkan Latar Belakang (Background) Putih pada Gambar/Foto dengan Corel PHOTO-PAINT X6

Doa Ketika Memakai dan Melepas Pakaian

Lia, Kakak Angkat Obama yang Tidak Diakui