Spanning Tree Protocol

Tujuan
* Agar dapat memahami prinsip kerja STP
* Agar dapat menentukan root bridge dan root port
* Agar dapat mengetahui peran Spanning Protocol Tree dalam layer 2 switching

Landasan teori
Definisi
Spanning Tree Protocol (disingkat STP) adalah sebuah protokol jaringan yang memastikan bahwa topologi loop-free untuk setiap jaringan area lokal bridge Ethernet yang berada di jaringan switch yang memungkinkan semua perangkat untuk berkomunikasi antara satu sama lain agar dapat mendeteksi dan mengelola redundant link dalam jaringan.
Maka dapat diambil kesimpulan bahwa Spanning tree Protokol adalah protokol manajemen link yang menyediakan redundansi sementara mencegah perulangan yang tidak diinginkan dalam jaringan.

Tanpa adanya Spanning Tree Protocol (STP), LAN dengan link yang redundant mengakibatkan adanya frame yang looping tanpa henti di dalam jaringan. Dengan STP, beberapa switch akan memblok interface/port-nya agar port tersebut tidak bisa lagi forwarding frames keluar. STP akan menentukan port mana yang harus diblok sehingga hanya 1 link saja yang aktif dalam satu segment LAN. Hasilnya, frame tetap bisa ditransfer antarkomputer tanpa menyebabkan gangguan akibat adanya frame yang looping tanpa henti di dalam network.



Tugas utama STP adalah menghentikan terjadinya loop-loop network pada network layer 2 (bridge atau switch). STP secara terus-menerus memonitor network untuk menemukan semua link, memastikan bahwa tidak ada loop yang terjadi dengan cara mematikan semua link yang redundant. STP menggunakan algoritma yang disebut spanning-tree algorithm (STA) untuk menciptakan sebuah topologi database, kemudian mencari dan menghancurkan link-link redundant. Dengan menjalankan STP, frame frame hanya akan diteruskan pada link-link utama yang dipilih oleh STP.

Komponen
1. Root bridge
Root bridge merupakan master bridge atau controlling bridge. Root bridge secara periodik mem-broadcast message konfigurasi. Message ini digunakan untuk memilih rute dan re-konfigure fungsi-2 dari bridge-2 lainnya bila perlu. Hanya da satu root bridge per jaringan. Root bridge dipilih oleh administrator. Saat menentukan root bridge, pilih root bridge yang paling dekat dengan pusat jaringan secara fisik.

2. Designated bridge
Suatu designated bridge adalah bridge-2 lain yang berpartisipasi dalam meneruskan paket melalui jaringan. Mereka dipilih secara automatis dengan cara saling tukar paket konfigurasi bridge. Untuk mencegah terjadinya bridging loop, hanya ada satu designated bridge per segment jaringan.

3. Backup bridge
Semua bridge redundansi dianggap sebagai backup bridge. Backup bridge mendengar traffic jaringan dan membangun database bridge. Akan tetapi mereka tidak meneruska paket. Backup bridge ini akan mengambil alih fungsi jika suatu root bridge atau designated bridge tidak berfungsi.

Bridge mengirimkan paket khusus yang disebut Bridge Protocol Data Units (BPDU) keluar dari setiap port. BPDU ini dikirim dan diterima dari bridge lainnya digunakan untuk menentukan fungsi-2 bridge, melakukan verifikasi kalau bridge disekitarnya masih berfungsi, dan recovery jika terjadi perubahan topology jaringan.
Perencanaan jaringan dengan bridge mengguanakan spanning tree protocol memerlukan perencanaan yang hati-hati. Suatu konfigurasi yang optimal menuntut pada aturan-aturan berikut ini:
1. Setiap bridge sharusnya mempunyai backup (yaitu jalur redundansi antara setiap segmen)
2. Packet-2 harus tidak boleh melewati lebih dari dua bridge antara segmen-2 jaringan
3. Packet-2 seharusnya tidak melewati lebih dari tiga bridge setelah terjadi perubahan topology.
Spanning tree protocol (STP) adalah layanan yang memungkinkan LAN switches dikoneksikan secara redundansi dengan memberikan suatu mekanisme untuk mencegah terjadinya suatu bridging loops.

Langkah percobaan

Bukalah Aplikasi Packet tracer yang tadi telah terinstall, dengan cara double klik pada icon yang berada di menu start ataupun di desktop.

Setelah itu akan muncul screen dari packet tracer yang sedang memuat komponen-komponen yang diperlukan.

Pada Packet Tracer yang telah terbuka kita pilih logical view untuk membuat konsep jaringan komputer.

Komponen-komponen yang yang diperlukan pada percobaan ini yaitu :
* 4 komponen PC
* 4 komponen kabel straight
* 4 komponen kabel cross
* 3 komponen switch
Masukan komponen PC dan switch dengan susunan seperti gambar dibawah.


Hubungkan keempat PC dan switch dengan menghubungkan kabel straight yang berada di Device Box pada bagian Connections lalu pilih Copper Straight-Over. Dengan ketentuan sebagai berikut :
PC 1 FastEthernet -> S2 FastEthernet 0/11
PC 2 FastEthernet -> S2 FastEthernet 0/18
PC 3 FastEthernet -> S2 FastEthernet 0/6
PC 4 FastEthernet -> S1 FastEthernet 0/3
Dan switch dengan switch menggunakan kabel Cross. Dengan ketentuan sebagai berikut :
S2 FastEthernet0/2 -> S3 FastEthernet0/2
S2 FastEthernet0/1 -> S1 FastEthernet0/1
S1 FastEthernet0/2 -> S3 FastEthernet0/1

Kemudian Mengatur IP address pada masing-masing PC, dengan cara klik icon pada PC, kemudian pada tampilan yang muncul pilih desktop.
Kemudian pada tampilan desktop pilih IP Configuration.
Kemudian setting IP address, Subnet Mask dan Default Geteway.

Dengan cara yang sama, aturlah IP address, Subnet Mask dan Default Geteway PC lain, sesuai dengan tabel berikut :

Setelah itu lihat untuk melihat konfirmasi bahwa semua port ditugaskan untuk VLAN 1, caranya klik icon switch 1 (S1), kemudian pilih CLI

Kemudian pada tampilan CLI tekan enter dan ketik sintaks berikut :
S1>enable
S1#show vlan

Mengkonfigurasi Parameter Saklar Dasar
1. Mengkonfigurasi switch S1
* Caranya klik icon switch 1 (S1), kemudian pilih CLI
* Kemudian tekan enter dan ketik sintaks berikut :
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Tampilannya sebagai berikut :

2. Mengkonfigurasi switch S2
* Caranya klik icon switch 2 (S2), kemudian pilih CLI
* Kemudian tekan enter dan ketik sintaks berikut :
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S2
S2(config)#senable secret clas
S2(config)#no ip domain-lookup
S2(config)#line console 0
S2(config-line)#password cisco
S2(config-line)#login
S2(config-line)#line vty 0 15
S2(config-line)#password cisco
S2(config-line)#login
S2(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Tampilannya sebagai berikut :


3. Mengkonfigurasi switch S3
* Caranya klik icon switch 3 (S3), kemudian pilih CLI
* Kemudian tekan enter dan ketik sintaks berikut :
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S3
S3(config)#enable secret class
S3(config)#no ip domain-lookup
S3(config)#line console 0
S3(config-line)#password cisco
S3(config-line)#login
S3(config-line)#line vty 0 15
S3(config-line)#password cisco
S3(config-line)#login
S3(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Tampilannya sebagai berikut :

Persiapan Jaringan
1. Nonaktifkan semua port dengan menggunakan perintah shutdown.
* Menonaktifkan switch 1 (S1)
* Ketik sintaks berikut, pada tampilan CLI :
S1(config)#interface range fa0/1-24
S1(config-if-range)#shutdown
S1(config-if-range)#interface range gi0/1-2
S1(config-if-range)#shutdown

* Menonaktifkan switch 2 (S2)
* Ketik sintaks berikut, pada tampilan CLI :
S2(config)#interface range fa0/1-24
S2(config-if-range)#shutdown
S2(config-if-range)#interface range gi0/1-2
S2(config-if-range)#shutdown

* Menonaktifkan switch 3 (S3)
* Ketik sintaks berikut, pada tampilan CLI :
S3(config)#interface range fa0/1-24
S3(config-if-range)#shutdown
S3(config-if-range)#interface range gi0/1-2
S3(config-if-range)#shutdown

2. Mengaktifkan kembali port pengguna pada S1 dan S2 dalam mode akses.
* Mengaktifkan switch 1 (S1)
* Ketik sintaks berikut, pada tampilan CLI :
S1(config)#interface fa0/3
S1(config-if)#switchport mode access
S1(config-if)#no shutdown

* Mengaktifkan switch 2 (S2)
* Ketik sintaks berikut, pada tampilan CLI :
S2(config)#interface range fa0/6, fa0/11, fa0/18
S2(config-if-range)#switchport mode access
S2(config-if-range)#no shutdown

3. Aktifkan port trunk pada S1, S2, dan S3.
* Mengaktifkan  trunk switch 1 (S1)
* Ketik sintaks berikut, pada tampilan CLI :
S1(config-if)#interface range fa0/1, fa0/2
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#no shutdown

* Mengaktifkan trunk switch 2 (S2)
* Ketik sintaks berikut, pada tampilan CLI :
S2(config-if-range)#interface range fa0/1, fa0/2
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#no shutdown

* Mengaktifkan trunk switch 2 (S2)
* Ketik sintaks berikut, pada tampilan CLI :
S3(config)#interface range fa0/1, fa0/2
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#no shutdown

4. Konfigurasi alamat manajemen antarmuka pada ketiga switch.
* Konfigurasi diswitch 1 (S1)
* Ketik sintaks berikut, pada tampilan CLI :
S1(config)#interface vlan1
S1(config-if)#ip address 172.17.10.1 255.255.255.0
S1(config-if)#no shutdown

* Konfigurasi diswitch 1 (S1)
* Ketik sintaks berikut, pada tampilan CLI :
S2(config)#interface vlan1
S2(config-if)#ip address 172.17.10.2 255.255.255.0
S2(config-if)#no shutdown

* Konfigurasi diswitch 1 (S1)
* Ketik sintaks berikut, pada tampilan CLI :
S3(config)#interface vlan1
S3(config-if)#ip address 172.17.10.3 255.255.255.0
S3(config-if)#no shutdown

Konfigurasi Spanning Tree
1. Konfigurasi diswitch 1 (S1)
* Ketik sintaks berikut, pada tampilan CLI :
S1#show spanning-tree

2. Konfigurasi diswitch 2 (S2)
* Ketik sintaks berikut, pada tampilan CLI :
S2#show spanning-tree

3. Konfigurasi diswitch 3 (S3)
* Ketik sintaks berikut, pada tampilan CLI :
S3#show spanning-tree

Hasil

Hasil yang diperoleh dari percobaan diatas adalah didapat topologi Spanning Tree yang dapat menyediakan Backup / stand by path untuk mencegah loop dan switch yang failed/gagal.

Komentar

  1. trima kasih atas infonya ..
    tlng kunjungi blog saya juga yaa ..
    http://jaketkuning.unsri.ac.id/elisyah/blog/1449/
    trima kasih sebelumny :)

    BalasHapus

Posting Komentar

Postingan populer dari blog ini

Tutorial Menghilangkan Latar Belakang (Background) Putih pada Gambar/Foto dengan Corel PHOTO-PAINT X6

Doa Ketika Memakai dan Melepas Pakaian