Rapid Spanning Tree Protocol

Tujuan
* Agar dapat mengetahui konsep Spanning Tree Protocol
* Agar dapat memahami perbedaan antar STP dan RSTP

Rapid spanning tree protocol (RSTP) – pertama kali diperkenalkan pada tahun 1982 sebagai pembaharuan dari STP (standar 802.1D). Menyediakan konvergensi stanning-tree yang lebih cepat ketika ada perubahan topologi. protokol yang memungkinkan sebuah jaringan untuk berfungsi baik dengan loops atau dalam topologi.

Perbedaan antara STP dan RSTP adalah pada kondisi yang ada, jika pada STP ada 5 kondisi dan RSTP hanya ada 2 kondisi.

Jembatan port RSTP :
- Root - Sebuah port forwarding yang port terbaik dari Nonroot-jembatan untuk Rootbridge.
- Ditunjuk - Sebuah port forwarding untuk setiap segmen LAN.
- Alternatif - Jalur alternatif ke jembatan akar. Jalur ini berbeda dengan menggunakan port root.
- Backup - backup A redundant path / ke segmen mana port lain jembatan sudah menghubungkan.
- Cacat - Tidak sepenuhnya bagian dari STP, seorang administrator jaringan secara manual dapat menonaktifkan port. RSTP adalah penyempurnaan dari saham STP dan karena itu sebagian besar karakteristik dasar operasi.
- Deteksi kegagalan root menukar dilakukan dalam 3 halo kali, yang 6 detik jika default halo kali belum diubah.
- Port dapat dikonfigurasi sebagai pelabuhan tepi jika mereka terpasang ke LAN yang tidak memiliki jembatan lain terlampir. Tepi ini port transisi langsung ke negara forwarding. RSTP masih terus memantau port untuk BPDUs dalam kasus jembatan tersambung. RSTP juga dapat dikonfigurasi untuk secara otomatis mendeteksi port tepi. Segera setelah jembatan mendeteksi BPDU datang ke tepi port, port menjadi port non-tepi.

Tidak seperti di STP, RSTP akan merespon BPDUs dikirim dari arah jembatan akar. Sebuah jembatan RSTP akan "mengusulkan" informasi pohon rentang untuk pelabuhan yang ditunjuk. Jika ada jembatan RSTP menerima informasi ini dan menentukan ini adalah informasi akar unggul, itu set semua port lain untuk membuang. Jembatan dapat mengirimkan sebuah "kesepakatan" untuk jembatan pertama mengkonfirmasikan informasi pohon superior spanning. Jembatan pertama, setelah menerima perjanjian ini, tahu bisa cepat transisi bahwa port ke keadaan forwarding melewati mendengarkan tradisional / transisi negara belajar. Hal ini pada dasarnya menciptakan efek mengalir jauh dari jembatan akar di mana setiap jembatan yang ditunjuk mengusulkan untuk tetangga untuk menentukan apakah itu bisa membuat transisi yang cepat. Ini adalah salah satu elemen utama yang memungkinkan RSTP untuk mencapai konvergensi kali lebih cepat dari STP.

Seperti dijelaskan dalam rincian peran pelabuhan di atas, RSTP mempertahankan cadangan rincian tentang status pembuangan port. Hal ini untuk menghindari timeout jika port forwarding saat ini adalah untuk gagal atau BPDUs tidak diterima pada port akar dalam interval tertentu.

Alat & Bahan
Software Cisco Packet Tracer 5.3

Praktikum
Dalam praktikum kali ini kita akan membuat simulasi jaringan STP sesuai dengan gambar skema topologi dibawah ini



Buat desain jaringan seperti berikut dan ikuti pengaturan IP Address, Subnet Mask dan Default Gateway dan VLAN pada addressing table.


Penempatan Port pada Switch 2


Addresing Table

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Setelah itu atur domain tiap switchnya

S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain Lab5
Changing VTP domain name from NULL to Lab5
S1(config)#vtp password cisco
Setting device VLAN database password to cisco
S1(config)#end
S2(config)#vtp mode client
Setting device to VTP CLIENT mode
S2(config)#vtp domain Lab5
Changing VTP domain name from NULL to Lab5
S2(config)#vtp password cisco
Setting device VLAN database password to cisco
S2(config)#end
S3(config)#vtp mode client
Setting device to VTP CLIENT mode
S3(config)#vtp domain Lab5
Changing VTP domain name from NULL to Lab5
S3(config)#vtp password cisco
Setting device VLAN database password to cisco
S3(config)#end

setelah itu atur mode vlan dan trunking mode nya
S1(config)#interface range fa0/1-4
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
S1(config-if-range)#no shutdown
S1(config-if-range)#end
S2(config)# interface range fa0/1-4
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#switchport trunk native vlan 99
S2(config-if-range)#no shutdown
S2(config-if-range)#end
S3(config)# interface range fa0/1-4
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99
S3(config-if-range)#no shutdown
S3(config-if-range)#end

setelah itu membuat VLAN di switch server
S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name faculty-staff
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name students
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name guest
S1(config-vlan)#exit

langkah selanjutnya yaitu memberikan ip addres pada tiap switchnya
S1(config)#interface vlan99
S1(config-if)#ip address 172.17.99.11 255.255.255.0
S1(config-if)#no shutdown
S2(config)#interface vlan99
S2(config-if)#ip address 172.17.99.12 255.255.255.0
S2(config-if)#no shutdown
S3(config)#interface vlan99
S3(config-if)#ip address 172.17.99.13 255.255.255.0
S3(config-if)#no shutdown

selanjutnya mengatur mode port pada tiap swichnya
S2(config)#interface range fa0/5-10
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 30
S2(config-if-range)#interface range fa0/11-17
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 10
S2(config-if-range)#interface range fa0/18-24
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#end
S2#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...
[OK]
S2(config)#interface range fa0/6, fa0/11, fa0/18
S2(config-if-range)#no shutdown

Atur prioritas untuk VLAN 1, 10, 20, dan 30 di S1 hingga 4096. Once again, the lower number indicates a higher priority for root selection.
S1(config)#spanning-tree vlan 1 priority 4096
S1(config)#spanning-tree vlan 10 priority 4096
S1(config)#spanning-tree vlan 20 priority 4096
S1(config)#spanning-tree vlan 30 priority 4096
S1(config)#exit

setelah itu kita hanya perlu mengubah mode spanning tree
S1(config)#spanning-tree mode rapid-pvst
S2(config)#spanning-tree mode rapid-pvst
S3(config)#spanning-tree mode rapid-pvst

Komentar

Postingan populer dari blog ini

Tutorial Menghilangkan Latar Belakang (Background) Putih pada Gambar/Foto dengan Corel PHOTO-PAINT X6

Doa Ketika Memakai dan Melepas Pakaian

Lia, Kakak Angkat Obama yang Tidak Diakui